Old versions of MT4 will be discontinued effective October 1, 2021

Updated: September 21, 2021

Dear Clients,

We would like to inform you that starting from 01.10.2021, the minimum supported version of MetaTrader 4 will be build 1320. This change will improve the performance of the entire trading platform and increase its stability. We recommend that you check your current terminal build and, if necessary, update it to the latest version. Terminals with older versions will no longer connect to AMarkets trading servers.

You can find out the current build of your MetaTrader 4 trading platform by clicking “Help – About”.

 

 

We remind you that the minimum required operating system for MetaTrader 4 is Windows 7. For a more stable performance, we recommend running your platform on a 64-bit version of Windows 10.

AMarkets App

AMarkets App

Free trading app for Android

Free trading app for iOS

ratings of app