AMarkets recommends upgrading your trading terminals

Dear Clients!

After March 1, 2019, MetaTrader 4 desktop terminal builds below 1118 and MetaTrader 4 Android terminals below 1104 will no longer be supported. This means that such terminals will not be able to connect to AMarkets’ trading servers.

Please make sure to update your trading terminals to the latest versions