AMarkets recommends upgrading your trading terminals MetaTrader 4

Dear Clients!

Earlier we have announced that old versions of MetaTrader 4 terminal were longer supported.

After July 1, 2019, MetaQuotes will discontinue support of all MetaTrader 4 client terminal builds below 1170. This means that such terminals will not be able to connect to AMarkets’ trading servers.

Please make sure to update your MetaTrader 4 trading terminals to the latest versions.